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Legal Information
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Safety Information

For your own safety, the safety of others, and to prevent damage to the product and vehicles upon 
which it is used, it is important that all instructions and safety messages in this manual and the 
accompanying Important Safety Instructions manual be read and understood by all persons 
operating, or coming into contact with the product, before operating. We suggest you store a copy 
of each manual near the product in sight of the operator.

For your safety, read all instructions. Use your diagnostic tools only as described in the 
Diagnostics Tool user’s manual. Use only manufacturer recommended parts and accessories with 
your diagnostic tools.

This product is intended for use by properly trained and skilled professional automotive 
technicians. The safety messages presented throughout this manual and the accompanying 
Important Safety Instructions manual are reminders to the operator to exercise extreme care when 
using this product.

There are many variations in procedures, techniques, tools, and parts for servicing vehicles, as 
well as in the skill of the individual doing the work. Because of the vast number of test applications 
and variations in the products that can be tested with this instrument, we cannot possibly 
anticipate or provide advice or safety messages to cover every situation. It is the responsibility of 
the automotive technician to be knowledgeable of the system being tested. It is essential to use 
proper service methods and test procedures. It is important to perform tests in an appropriate and 
acceptable manner that does not endanger your safety, the safety of others in the work area, the 
equipment being used, or the vehicle being tested.

It is assumed that the operator has a thorough understanding of vehicle systems before using this 
product. Understanding of these system principles and operating theories is necessary for 
competent, safe and accurate use of this instrument.

Before using the equipment, always refer to and follow the safety messages and applicable test 
procedures provided by the manufacturer of the vehicle or equipment being tested. Use the 
product only as described in it’s user manual. Use only manufacturer recommended parts and 
accessories with your product.

Read, understand and follow all safety messages and instructions in this manual, the 
accompanying Important Safety Instructions manual, and on the test equipment.

Environmental Conditions:

• This product is intended for indoor use only

• This product is rated for Pollution Degree 2 (normal conditions)
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Safety Information Safety Signal Words

Safety Signal Words
All safety messages contain a safety signal word that indicates the level of the hazard. An icon, 
when present, gives a graphical description of the hazard. Safety Signal words are:

Indicates an imminently hazardous situation which, if not avoided, will result in death or serious 
injury to the operator or to bystanders.

Indicates a potentially hazardous situation which, if not avoided, could result in death or serious 
injury to the operator or to bystanders.

Indicates a potentially hazardous situation which, if not avoided, may result in moderate or minor 
injury to the operator or to bystanders.

Safety Message Conventions
Safety messages are provided to help prevent personal injury and equipment damage. Safety 
messages communicate the hazard, hazard avoidance and possible consequences using three 
different type styles:

• Normal type states the hazard.

• Bold type states how to avoid the hazard.

• Italic type states the possible consequences of not avoiding the hazard.

An icon, when present, gives a graphical description of the potential hazard.

Safety Message Example

Risk of unexpected vehicle movement.

• Block drive wheels before performing a test with engine running.

A moving vehicle can cause injury.

Important Safety Instructions
For a complete list of safety messages, refer to the accompanying Important Safety Instructions 
manual provided with your diagnostic tool or on our website. See the website contact information 
on page ii for website addresses.

SAVE THESE INSTRUCTIONS
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Chapter 1 Using This Manual

1.1   Content
This manual contains basic operating instructions and is structured in a manner to help you 
become familiar with and perform basic operations.

The illustrations in this manual are intended as reference only and may not depict actual screen 
results, information, functions or standard equipment.

1.2   Conventions
The following conventions are used.

1.2.1  Terminology

The terms “Scanner” and “Scanner function” are used to describe the Scanner Function(s) of the 
diagnostic tool.

Examples:

• Select Scanner from the Home screen.

• From the Scanner main menu select Continue.

• The Scanner function provides many diagnostic tests.

The term “select” describes tapping/touching an icon on the touch screen, or highlighting an icon 
or menu choice and then selecting the confirmation menu choice such as Continue, Accept, OK, 
Yes, or other similar choice.

Abbreviated example for the following procedure: “Select Brightness” 

1. Navigate to and highlight the Brightness selection.

2. Select OK, or similar, button.

1.2.2  Symbols

Different types of arrows are used. The “greater than” arrow (>) indicates an abbreviated set of 
selection (navigation) instructions.

Abbreviated example for the following procedure: “Select Tools > Connect-to-PC”

1. Select Tools from the home screen.

2. Highlight Connect-to-PC on the Tools menu.

3. Select Connect-to-PC.

The solid arrows (e, c, d, b) are navigational instructions for the four directions of the directional 
buttons.

Example: Press the down d arrow.
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Using This Manual Conventions

1.2.3  Bold Text

Bold emphasis is used in procedures to highlight selectable items such as control buttons, icons 
and menu options.

Example: Press the OK button

1.2.4  Notes and Important Messages

The following messages are used.

Notes

A NOTE provides helpful information such as additional explanations, tips, and comments.

Example:

NOTE:
i For additional information refer to...

Important

IMPORTANT indicates a situation which, if not avoided, may result in damage to the test 
equipment or vehicle.

Example:

IMPORTANT:
Do not disconnect the data cable while the diagnostic tool is communicating with the ECM.

1.2.5  Hyperlinks

Hyperlinks, or hot links, that take you to other related articles, procedures, and illustrations are 
available in electronic documents. Blue colored text indicates a selectable hyperlink.

Example:

IMPORTANT:
Read all applicable Safety Information before using this diagnostic tool!

1.2.6  Procedures

An arrow icon in the left-margin area indicates a procedure.

Example:

z To change screen views:

1. Select the Graph icon.

The dropdown menu displays.

2. Select an option from the menu.

The screen layout changes to the format selected.
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Chapter 2 Introduction

The ShopStream Connect™ (SSC) software is PC-based software that extends the capabilities of 
your diagnostic tools. Using ShopStream Connect software with your diagnostic tools allows you 
to do the following:

• View, Print, and Manage data saved from your Diagnostic tool.

• Move and copy your data between the diagnostic tool and your PC.

• View and Print trouble codes saved with select diagnostic tools. This allows you to share the 
data in a report format with vehicle owners or other technicians.

• Add or edit notes and comments to diagnostic tool data files.

• Download and install diagnostic tool software updates and upgrades.

ShopStream Connect can be used with the following diagnostic tools:

Note: Application and features will vary

ETHOS Family

Use the quick links, to view 

connection instructions 

ETHOS®

ETHOS®+

SOLUS Family

SOLUS™

SOLUS™ PRO

SOLUS Ultra®

SOLUS™ Edge

MODIS Family

MODIS™

MODIS™ Ultra

MODIS™ Edge

Vantage Family

Vantage PRO™ 

VANTAGE® Ultra

MICROSCAN Family

MICROSCAN®

MICROSCAN® III
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Chapter 3 Installation

This chapter describes how to download and install ShopStream Connect (SSC) on your PC.

3.1   Verifying Minimum PC Requirements
Before installing the software, verify your PC meets the following requirements:

IMPORTANT:
If your PC does not meet the following minimum requirements, do not attempt to install 
ShopStream Connect.

• System Properties:

– Operating system—Windows® XP, 7, 8/8.1 or 10 (Windows XP must be updated to 
Microsoft .NET Framework Version 4.0)

– Processor—Intel® Pentium 4 or later, or equivalent

– Memory—512MB RAM Minimum, 1GB RAM Recommended

• Hard Drive—500 MB free space

• CD-ROM, DVD, or DVD-ROM drive (optional)

• Display Resolution XGA 1024 x 768 or Higher

• USB 2.0 or later

• Internet Explorer 6.0 or higher

• Internet connection

• Adobe® Reader software (free download at www.adobe.com/products/reader)

The following may also be needed, depending on the diagnostic tool:

• USB cable (most models), see “Connecting the USB Cable and Communicating” on page 12

• A CompactFlash® (CF) card reader (for updating SOLUS, Vantage PRO, and early MODIS 
diagnostic tools).

3.1.1  Verifying PC System Properties

The following procedures will vary depending on your PC operating system. Multiple methods are 
listed for convenience. 

z To check PC system properties:

• Navigate to Control Panel, then select System or Properties.

• Navigate to Computer then select System Properties.
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Installation Download and Installation

z To check PC hard drive free space:

1. Navigate to Computer, My Computer, or Windows Explorer.

2. Select your local drive, or the drive where the SSC software will reside and select Properties 
or View > Details (Figure 3-1).

Figure 3-1  Typical PC hard drive free space details

3.2   Download and Installation

z To download the SSC software:

1. From your PC, using your Internet browser, go to the ShopStream Connect website. See 
website information on page “ii” of this manual.

2. Download the SSC software.

z To install the SSC software:

1. If the SSC autorun installer does not automatically start the installation, double-click the SSC 
installation file ShopStreamConnect.exe, that downloaded onto your PC.

The Setup Wizard launches.

2. Select Next (Figure 3-2).
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Installation Download and Installation

Figure 3-2  Typical Welcome screen

3. Choose your geographical market location.

4. From the License Agreement screen:

a. Scroll to read through the entire Snap-on Incorporated Software License Agreement.

b. Select the I accept the terms of the license agreement check box.

c. Select Next to continue (Figure 3-3).

Figure 3-3 Typical License Agreement screen

5. Select Install to begin installation (Figure 3-4).

Installation status screens display to indicate progress as the program installs.



9

Installation Download and Installation

Figure 3-4 Typical install and status screens

6. Select Finish. (Figure 3-5).

Figure 3-5 Typical Complete screen

A shortcut icon is added to the desktop (Figure 3-6).

Figure 3-6 ShopStream Connect icon
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Installation Starting SSC

3.3   Starting SSC

zTo start SSC:

If not already installed, install the ShopStream Connect software on your PC. See, “Installation” on 
page 6.

Starting the software can vary depending on the Windows operating system installed on your PC 
and your setup preferences. Typically SSC can be started from:

• The ShopStream Connect icon on the Windows desktop (automatically created during 
installation)

– Double-click ShopStream Connect icon .

• The Windows Start menu 

– Select directly from the Start Menu (Figure 3-7 left) programs if available, or

– Select Start > All Programs > ShopStream Connect > ShopStream Connect 
(Figure 3-7 right).

Figure 3-7  Typical Windows 7 start menu selections
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Installation Exiting SSC

3.4   Exiting SSC

zTo exit SSC:

Select Exit from the dropdown File menu (Figure 3-8).

Figure 3-8  Exit selection
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Chapter 4 Diagnostic Tool Connection

This chapter describes how to connect the diagnostic tool to your PC and establish 
communication.

4.1  Connecting the USB Cable and Communicating
There are two different USB cables used to connect diagnostic tools to PCs. The type of cable 
used is dependent upon the diagnostic tool USB connection.

Both cables use an A-Type USB connector on one end (shown on left in illustrations below) to 
connect to a PC. The other end of the cable, has either a Mini-b (5-pin) or B-Type USB connector.

zConnecting the USB cable to the diagnostic tool and PC:

1. Connect the A-Type end of the cable into the USB jack on your PC.

2. Connect the other end of the cable into the USB jack on the diagnostic tool.

zEstablishing communication:

Establishing communication between the PC and diagnostic tool, varies depending on the 
diagnostic tool.

In the following table, click-on the image to see the communication instructions for that diagnostic 
tool.

USB cables types

Used with ALL diagnostic 
tools, except SOLUS and 
MICROSCAN

Used only with SOLUS and 
MICROSCAN diagnostic 
tools

Mini-bA-Type

B-Type

A-Type
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Diagnostic Tool Connection Connecting the USB Cable and Communicating

NOTE:
i The diagnostic tool illustrations shown are for reference only.

Diagnostic Tool
USB 

Connector 
Type

Location of USB connector
(click image to see communication instructions)

ETHOS
 see page 17

Mini-b

ETHOS +
 see page 15

Mini-b

MODIS ULTRA
 see page 15

Mini-b

MODIS Edge
 see page 15

Mini-b

SOLUS
 see page 16

B-Type

SOLUS PRO
 see page 16

Mini-b

SOLUS Ultra
 see page 15

Mini-b
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Diagnostic Tool Connection Connecting the USB Cable and Communicating

NOTE:
i The screen images shown in the following sections are for reference only, and may not depict actual screens.

SOLUS Edge
 see page 15

Mini-b

Vantage PRO
 see page 16

Mini-b

VANTAGE Ultra
 see page 15

Mini-b

MICROSCAN
 see page 18

B-Type

MICROSCAN III
 see page 18

Mini-b

MODIS
 see page 19

Mini-b
(on circuit board, 

above the compact 
flash card under 
the left handgrip)

NOTE: Older MODIS diagnostic tools do not have a USB jack on the circuit board by the side CF card slot, and 
they cannot be connected to a PC with a cable. However, saved files can be viewed with ShopStream Connect 
and older diagnostic tools can be upgraded to current specifications. Refer to "Communicating with Early MODIS 
diagnostic tools" on page 61 for additional information.



15

Diagnostic Tool Connection Connecting the USB Cable and Communicating

4.1.1 MODIS Ultra, MODIS Edge, SOLUS Ultra, SOLUS Edge, 
VANTAGE Ultra, and ETHOS+

zEstablishing communication:

1. Connect the diagnostic tool to the PC using the applicable USB cable, see "Connecting the USB Cable 
and Communicating" on page 12.

2. Connect the AC/DC power adapter, then turn on the diagnostic tool.

3. From the Home screen, select Tools > Connect-to-PC (Figure 4-1 upper left).

4. Select Continue (Figure 4-1 right center).

The now in Connect-to-PC mode screen displays (Figure 4-1 lower left).

Figure 4-1 Connect-to-PC screens

5. On the PC, start the ShopStream Connect software (if it does not automatically start), see "Connecting 
the USB Cable and Communicating" on page 12.

ShopStream Connect should default to display the data stored on your diagnostic tool. If not, select 
your applicable diagnostic tool from the end of the file directory list.

To Stop communication select Exit (Figure 4-1 lower left).

This device is now in Connect-to-PC mode.

Press  X to exit.
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Diagnostic Tool Connection Connecting the USB Cable and Communicating

4.1.2 SOLUS, SOLUS PRO, and Vantage PRO

zEstablishing communication:

1. Connect the AC/DC power adapter, then turn on the diagnostic tool.

2. From the Main Menu, select UTILITIES > Connect to PC (Figure 4-2), and then press Y.

Figure 4-2 Typical Utilities Menu

3. Press Y to turn off the diagnostic tool when the configure for Connect to PC message displays.

4. Turn on the diagnostic tool.

 The Connect-to-PC message displays (Figure 4-3).

Figure 4-3  Typical Connect to PC mode messages

5. Connect the diagnostic tool to the PC using the applicable USB cable, see "Connecting the USB Cable 
and Communicating" on page 12.

If a “removable disk” dialog automatically opens on your PC, select Cancel.

6. On the PC, start the ShopStream Connect software (if it does not automatically start), see "Connecting 
the USB Cable and Communicating" on page 12.

ShopStream Connect should default to display the data stored on your diagnostic tool. If not, select 
your applicable diagnostic tool from the end of the file directory list.
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Diagnostic Tool Connection Connecting the USB Cable and Communicating

4.1.3 ETHOS

zEstablishing communication:

1. Connect the AC/DC power adapter, then turn on the diagnostic tool.

2. Connect the diagnostic tool to the PC using the applicable USB cable, see "Connecting the USB Cable 
and Communicating" on page 12.

3. On the diagnostic tool, simultaneously hold down the Y/a and N/x buttons, and then press the Power 
button.

The Service Menu displays (Figure 4-4).

Figure 4-4 Service menu

4. From the Service Menu, select PC-LINK.

IMPORTANT:
Unless you are specifically instructed to do so and have precise instructions, DO NOT attempt to 
use any other functions on the Service Menu. Improper use of Service Menu functions can corrupt 
the internal file structure and render the diagnostic tool inoperative.

5. On the PC, start the ShopStream Connect software (if it does not automatically start), see "Connecting 
the USB Cable and Communicating" on page 12.

If a “removable disk” dialog automatically opens on your PC, select Cancel.

ShopStream Connect should display the data stored on your ETHOS diagnostic tool. If not, select 
ETHOS from the end of the file directory list.

Once communication is established between your PC and ETHOS, the Mounting screen displays on 
your ETHOS diagnostic tool (Figure 4-5).

Figure 4-5 Mounting screen
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Diagnostic Tool Connection Connecting the USB Cable and Communicating

4.1.4 MICROSCAN

zEstablishing communication:

1. Connect the diagnostic tool to the PC using the applicable USB cable, see "Connecting the USB Cable 
and Communicating" on page 12.

The MICROSCAN automatically powers up and displays the service menu.

2. Select Connect to PC from the menu (Figure 4-6), then press Y to make the selection.

Figure 4-6 Connect t.o PC screen

The MICROSCAN screen changes to indicate it is now connected to the PC.

3. On the PC, start the ShopStream Connect software (if it does not automatically start), see "Connecting 
the USB Cable and Communicating" on page 12.

4. ShopStream Connect should default to display the data stored on your MICROSCAN diagnostic tool. 
If not, select MICROSCAN from the end of the file directory list.

4.1.5 MICROSCAN III

zEstablishing communication:

1. Connect the diagnostic tool to the PC using the applicable USB cable, see "Connecting the USB Cable 
and Communicating" on page 12.

The MICROSCAN III automatically powers up and displays the USB Menu (Figure 4-7).

Figure 4-7 USB menu

2. Select the Connect to PC icon (Figure 4-7).

The MICROSCAN III screen changes to indicate it is now connected to the PC.

3. On the PC, start the ShopStream Connect software (if it does not automatically start), see "Connecting 
the USB Cable and Communicating" on page 12.

4. ShopStream Connect should default to display the data stored on your MICROSCAN III diagnostic 
tool. If not, select MICROSCAN III from the end of the file directory list.
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Diagnostic Tool Connection Connecting the USB Cable and Communicating

4.1.6 MODIS

zEstablishing communication:

IMPORTANT:
Older MODIS diagnostic tools do not have a USB jack, and cannot be connected to a PC using a 
USB cable. However, saved files can be viewed using ShopStream Connect. 
See "Communicating with Early MODIS diagnostic tools" on page 61 for additional information.

1. Connect the AC/DC power adapter, then turn on the diagnostic tool.

2. From the Main Menu, select UTILITIES > Connect to PC, and then press Y.

3. Press Y to turn off the diagnostic tool when the configure for Connect to PC message displays.

4. Turn off the diagnostic tool.

The Connect to PC message displays (Figure 4-8)

Figure 4-8 Connect to PC mode message

5. Connect the diagnostic tool to the PC using the applicable USB cable, see "Connecting the USB Cable 
and Communicating" on page 12.

IMPORTANT:
A strain relief clip must be installed (Figure 4-9) to help secure the connector to the circuit board, 
contact Technical Support for information.

1— without strain relief clip

2— with strain relief clip

Figure 4-9 

If a “removable disk” dialog automatically opens on your PC, select Cancel.

6. On the PC, start the ShopStream Connect software (if it does not automatically start), see "Connecting 
the USB Cable and Communicating" on page 12.

ShopStream Connect should default to display the data stored on your MODIS diagnostic tool. If not, 
select MODIS from the end of the file directory list.
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Chapter 5 Basic Operation and 
Navigation

5.1   Main Screen Layout
The following explains the screen layout for ShopStream Connect™ software.

1— Notes Window—allows you add notes to select data files. Select Save from the menu 
bar to save your notes. NOTE: Not all file types allow notes, the Notes window will be 
grayed out when a file type that does not support notes is highlighted. Some image files 
may display notes for reference purposes (the notes are grayed out and not editable).

2— File directory structure—displays the file directory structure of your PC in standard 
Windows format, and shows any connected diagnostic tools at the bottom of the data list.

3— Data Manager Toolbar—provides control icons that perform a variety of operations on 
data files.

4— Main Menu bar—contains File, Edit, Tools, and Help menus.

5— Tabs—provides access to data files and presets stored on the diagnostic tool or on the 
PC, and also allows viewing of software revision details of the diagnostic tool.

6— Main display—shows stored data files details. NOTE: The files listed are sortable 
(ascending/descending) by clicking on the column tab at the top (e.g. File Name, Type, 
etc.) Sort preferences are saved when the ShopStream Connect program is closed.

7— Preview—displays a sample of the file if the selected file is a image file. 

Figure 5-1 ShopStream Connect screen layout
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Basic Operation and Navigation Main Menu Bar

5.2   Main Menu Bar
The Main Menu Bar includes the following menu options. 

• File

• Edit

• Tools

• Help

Descriptions are provided in the following sections.

5.2.1  File Menu

The following functions are available from the File menu:

• Exit—Closes the ShopStream Connect software.

• Open File—This function is used to open data files for viewing. The ShopStream Connect 
software lets you view data files stored on both the computer and the diagnostic tool. This 
operation is also available with a right-click of the mouse. 

• Copy to...—This function creates a duplicate of the selected files at the other location (PC if 
the file is on the diagnostic tool or diagnostic tool if the file is on the PC). This operation is also 
available with a right-click of the mouse.

• Move to...—This function moves selected files to another location (to the PC from the 
diagnostic tool, or to the diagnostic tool from the PC). This operation is also available with a 
right-click of the mouse.

• Delete—This function erases the selected files. This operation is also available with a right-
click of the mouse.

• Edit—Edit lets you quickly change the name of a file, or depending on the file type, add 
vehicle information and/or rename a data file. This operation is also available with a right-click 
of the mouse.

• Email—This function starts an E-mail message with a copy of file selections attached. This 
operation is also available with a right-click of the mouse.

• Refresh File List—Resamples and cleans up the display screen.

• Print—Sends the current screen to a printer.

5.2.2  Edit Menu

The Edit menu functions, follow Windows operational standards.

The following functions are available from the Edit menu:

• Cut File(s)—Removes the selected file and places it on the clipboard.

• Copy File(s)—Copies the selected file to the clipboard.

• Paste File(s)—Inserts the contents of the clipboard at the current location.
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Basic Operation and Navigation Main Menu Bar

5.2.3  Tools Menu

The Tools menu includes the following options:

• Update Software

• Options

Update Software

This function allows you to download updates and upgrades for your diagnostic tools and 
ShopStream Connect software. See “Updating and Upgrading Software” on page 56.

Options
This function allows you to enter shop information to be added to printed files and to change the 
location of the saved data files on the PC. Selecting Options opens a submenu that offers the 
following:

• Autostart—automatically launches ShopStream Connect whenever a diagnostic tool in 
Connect-to-PC mode is connected to the computer.

• Edit Shop Info—allows you to add your shop name and information to printed files.

• Change ShopStream Data Folder Path—allows you to select a different target destination 
for the diagnostic tools folder on your PC.

Autostart
ShopStream Connect automatically launches if a diagnostic tool is in Connect-to-PC mode, or the 
CF card from a MODIS, SOLUS, or Vantage PRO, is recognized by your PC when Autostart is 
active. This feature can be switched off and on by selecting it from the options submenu. A check 
mark alongside the name indicates Autostart is active.
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Edit Shop Info

Selecting Edit Shop Info opens a dialog box that allows you to enter the name address, and 
phone number for your shop, which can be included as a header on printed files. The date and 
time are automatically placed on the top line, and messages of up to three lines can also be added 
below the shop information. A preview panel at the bottom of the box shows how the information 
will appear on a print out (Figure 5-2).

Figure 5-2  Edit Shop Info dialog box

Check the “Use Shop Info in Printout Header” box to automatically include the header on printed 
files. Select Edit Shop Info from the Options submenu to modify or add messages before printing.
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Change ShopStream Data Folder Path

When a diagnostic tool is initially connected to a PC using ShopStream Connect, a diagnostic tool 
folder is created and named after the connected tool (e.g. ETHOS+, SOLUS, MODIS Ultra, etc). 

Selecting Change ShopStream Data Folder Path allows you to change the location of the 
diagnostic tool folder. Selecting this option opens a dialog box that allows you to browse the menu 
structure on your computer (Figure 5-3). Follow the onscreen instructions to select or create your 
new “target destination” folder and/or location.

Figure 5-3 

5.2.4  Help Menu
The Help menu includes useful information and links to help you get acquainted with and learn 
how to use ShopStream Connect. 

Figure 5-4 Help menu

About ShopStream Connect - Displays ShopStream Connect software version information.
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Whats New - Opens a submenu of links to learn about new platform information, accessories and 
the Subscription Manager Feature.

• ShopStream Connect Subscription Manager Feature (User Manual Link).

• What's New in Platform Coverage (Webpage Link).

• Optional Platform Accessories (Webpage Link).

ShopStream Connect Basics - opens quick links to the following topics in the User Manual.

• How to transfer files from diagnostic tool to PC.

• How to view files.

• How to download and install a software service release using Update Manager.

• How to download and install a software upgrade using Subscription Manager.

Manuals and Instructions - opens quick links to the User Manual and Installation Instructions.

• ShopStream Connect Installation Instructions (User Manual Link).

• ShopStream Connect User Manual.

Support - opens quick links found on the Snap-on Diagnostic webpage.

• ShopStream Connect FAQ's - lists Frequently Asked Questions about ShopStream Connect.

• ShopStream Connect User Forum - connect with other ShopStream Connect users to ask 
questions and find answers to your questions.

• Customer Support - lists customer support contact information.

5.3   Data Manager Screen Controls and Icons

5.3.1  Display Tabs
Tabs positioned at the top of the ShopStream Connect main display control the visible file 
information. The active tab is highlighted.

1— Data—displays a list of the data files on the diagnostic tool or stored on the PC.

2— Presets—displays a list of the preset files stored in the diagnostic tool or PC memory. 
This tab only displays when connected to a diagnostic tool that has presets, such as 
MODIS or Vantage PRO.

3— System Info—displays the serial number and version number of the connected 
diagnostic tool.

Figure 5-5 Tabs
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Data Tab

A typical ShopStream Connect data screen is shown below:

1— File directory structure—shows the file directory structure in Windows format.

2— Main display—shows a list of diagnostic tool data stored in the directory selected in the 
file structure frame.

3— Preview—shows a sample of the selected image file.

Figure 5-6 Data screen

System Info Tab

Figure 5-7 System Info Tab
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NOTE:
i The System information tab is only displayed when a diagnostic tool is connected and 

communicating with the PC. To view the tab, select (highlight) the diagnostic tool (drive) from the 
file directory structure list as shown in (Figure 5-6).

The System information screen displays details about the currently installed software in the 
display area of the screen. System information includes:

• Serial Number—used to uniquely identify your diagnostic tool.

• Bundle Number—used to identify the software release date.

• Version Number—used to identify the specific software version.

5.3.2  Controls
A mouse or keyboard can be used to navigate the program.

Using a Mouse
• Left mouse button:

– Select a toolbar control

– Select an item from a drop-down menu

– Operate the on-screen arrow keys

• Right mouse button:

– Open the context sensitive menu

Using Drag and Drop

Files stored on the computer may be moved in the file directory structure frame by using 
Windows-standard drag-and-drop functionality. ShopStream Connect creates individual “Files” 
folders for each diagnostic tool (e.g. ETHOS, MODIS, MODIS Ultra, SOLUS, SOLUS PRO, 
Vantage PRO) when the software installs. Drag and drop files from the list to a folder.

Using the Keyboard
• Left, Right, Up, Down arrow keys:

– Move the control selection highlight around the menus and tabs

• Use the Enter key to:

– Activate a selection

• Use the Esc key to:

– Exit a function
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5.3.3  Data Manager Toolbar Icons
This section explains toolbar icon operations, refer to “Main Screen Layout” on page 20.

Figure 5-8 

The following icons are used in the toolbar:

Open

The ShopStream Connect software lets you to use your computer to view data files stored on both 
the computer and the diagnostic tool.

z To view a file:

1. Select the Data tab.

2. Highlight the file that you wish to view.

3. Select Open from the toolbar.

The selected file displays on the computer screen (Figure 5-9).

1 Open Opens the highlighted file.

2 E-mail Allows you to send data files by e-mail (if default e-mail is configured).

3 Edit
Allows editing of the data file name, vehicle year, make, component, and 
condition.

4 Delete Erases the selected files from diagnostic tool or PC memory.

5 Copy To
Copies data and preset files between the computer and the diagnostic 
tool internal memory.

6 Move To
Transfers data and preset files between the computer and the diagnostic 
tool internal memory.

7 Save
Saves the open file. This function is only available after a file has 
changed.
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Figure 5-9 BMP file display

NOTE:
i You can also open a file by selecting File > Open File from the File menu or by double-clicking the 

selected file name.

Email 
This function sends a copy of selected files from your PC or diagnostic tool via E-mail.

NOTE:
i The ShopStream Connect Email feature uses the default e-mail program configured on your 

computer. If a default e-mail program has not been configured, an error message displays. Default 
e-mail configuration setup procedures vary depending on you operating system (OS) (e.g. WinXP, 
Win7, Win10, etc). Review your Windows Help information for default e-mail setup procedures.   

z To use the Email function:

1. Select the Data tab.

A list of available files displays.

2. From the on-screen list, highlight the file you wish to send.

3. From the toolbar, select Email.

An e-mail message window opens, with the selected file(s) attached.

4. Enter the e-mail address, subject, message text.

5. Select Send.
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Edit 
Edit lets you quickly change the name of an image file, or add vehicle information and rename a 
data file.

z To edit a file:

1. Select the Data tab.

2. With the file that you wish to edit highlighted, select Edit from the toolbar.

The Edit File Information window opens (Figure 5-10).

Figure 5-10 Edit File Information window

3. For a data file, either use the dropdown menus to select the year, make, component, and 
condition, or type in the information.

4. Type in the new name for the file.

NOTE:
i File Name is the only editable field, for image file types.

5. Select OK to close the window.

Delete
Files stored on the computer are typically sent to the recycle bin on your PC but vary depending 
on your Windows settings. Files stored in diagnostic tool memory are always permanently deleted.

z To delete a file:

1. Select the Data tab.

2. Highlight the file that you wish to delete.

3. Select Delete from the toolbar.

4. A confirmation screen displays:

a. Select Yes to permanently erase the file.

b. Select No to cancel.
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Copy To
The Copy To function creates a duplicate of the selected file or files on either the PC Data Folder 
or the diagnostic tool. Depending on where the original files reside, the duplicates copy to the 
other device. Select Copy To and a dropdown menu opens allowing you to choose where the file 
will be copied to. The original files are still available in the original location.

Move To 
Use the Move To function to move files between the diagnostic tool and your PC.

z To move a file:

1. Select the Data tab.

A list of files (if available) displays.

2. From the list, select one or multiple files to move.

3. Select Move To.

A dropdown menu displays.

4. Select the location, either PC Data Folder or diagnostic tool.

The selected files move to the selected location. 

Save
Saves the open file. This function is only available after a file has changed.
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Data and image files can be viewed using the Data Manager Viewers. There are multiple viewers 
that open the various data and image file extensions saved on diagnostic tools.

NOTE:
i File extension types vary depending on the diagnostic tool. Not all the file extensions described 

here may be available on your diagnostic tool.

• Scanner DataViewer - Opens files with the following extensions:

– .pids - ShopStream Scanner “movie” 

– .scm - Scanner “movie”

– .scp - Scanner Snapshot

– .scs - Scanner Screen Snapshot

– .spm - ETHOS Scanner “movie”

– .Icm - Microscan Scanner “movie”

• Scope File Viewer - Opens files with the following extensions:

– .ism - Ignition Scope “movie”

– .isp - Ignition Scope Snapshot 

– .lsm - Lab Scope “movie”

– .lsp - Lab Scope Snapshot

– .lss - Lab Scope Screen Snapshot

– .mmm - Multimeter “movie”

– .mmp - Multimeter snapshot

– .mms - Multimeter Screen Snapshot

– .vsm - Verus Scope “movie”

– .vss - Verus Scope Screen Snapshot

• Image Viewer - Opens files with the following extensions:

– .bmp - Screen Snapshot (bitmap image file)

– .jpg - Screen Snapshot (JPEG image file)

– .sps - Scanner Screen Snapshot 

• Scanner Codes Viewer - Opens files with the following extensions:

– .xml - Scanner Code Files
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6.1   Scanner DataViewer
Your ShopStream Connect software allows you to view data files recorded with your diagnostic 
tool on you PC. When a Scanner data file is selected, it opens and displays in the Scanner 
DataViewer (Figure 6-1). Scanner DataViewer allows you to custom configure the displayed data 
in a number of ways, and also provides a number of navigation options.

Scanner DataViewer - Opens .pids, .scm, .scs, .scp,.spm, and .lcm file extensions

1— Menu bar

2— Display toolbar

3— Graph display

4— Properties icon

5— Vertical Scroll bar

6— Zoom controls

7— Slider bar

8— Navigation toolbar

9— Parameter text list

10—Highlighted PIDs - indicates graphs currently displayed 

11—Parameter configuration tabs
Figure 6-1 Scanner Data Viewer
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6.1.1  Menu Bar

The menu bar at the top of the screen contains the File, View, Tools, and Help menus.

File Menu

The File menu offers the following selections (Figure 6-2):

Figure 6-2 Scanner DataViewer File menu

• Load—locate and open data files, launches a navigation window

• Print—print selected PIDs

• Print Preview—preview PIDs before printing

• Exit—closes Scanner DataViewer

When Print or Print Preview is selected, a dialog box opens that allows you to choose (Figure 6-3):

• Which PIDs to print

• To print only as a list

• To print only as a screenshot

• How many PIDs graphs print per page

• Printed font

Figure 6-3 
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z To use Print or Print Preview:

1. From the dialog box select the PIDs to be printed. A checked box indicates the PID will be 
printed. 

Use the Select All check box to simultaneously select all the PIDs at once.

By default, PID graphs will be printed. 

– To print as a PID text list, select the Print text list check box. 

– To print a screenshot, select the Print Screenshot check box. 

2. To change the printed font, select Change.

3. Once all selections are made, select OK.

A standard print dialog box opens.

4. Select OK to print.

a. If Print was selected, the file is sent to the printer.

b. If Print Preview was selected, a preview window opens (Figure 6-4). Select the printer 
icon to send the file to the printer.

The following examples, show:

• Default PID graphs print preview Figure 6-4 (left)

• PID text list print preview Figure 6-4 (right)

• Screenshot print preview Figure 6-5

Figure 6-4 
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Figure 6-5 

View Menu

The View menu allows you to change how data is displayed on the screen (Figure 6-6).

Figure 6-6 Scanner DataViewer View menu

Select from the following menu options:

• Text Only—shows all parameters and their values as text only

• Graphs Only—shows all parameters as graphs only

• Text and Graphs—shows all parameters and their values as text in the left panel of the 
screen, and shows them as graphs in the right panel of the screen
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Tools Menu

The Tools menu allows you opens the Properties dialog box (Figure 6-7).

Figure 6-7 Properties dialog box

NOTE:
i The Properties icon on each graph also opens the Properties dialog box (Figure 6-7).

The Properties dialog box includes three primary sections:

• Application Theme 

• Shared Graph Properties

• Individual Properties

Application Theme

• Application Theme - overall graph display properties. There are two settings: 

– Default - displays graphs with a black background

– Printer Friendly - displays graphs with a white background.

See (Figure 6-8) for examples.



38

Viewing Files Scanner DataViewer

Figure 6-8 View Settings - Default (left) and Printer Friendly (right) 

Shared Graph Properties

This section provides settings for all graphs.

• Show Grid Lines (check box)—when selected, a line displays at each major division of the 
graphs.

• Display Item—used to view the display color of the listed items. Highlight an item, and the 
associated color appears in the Color box.

– Color Change (button)—use to change the color of the highlighted item, select to open 
the color palate.

• Sweep—enter a number to adjust the number of data frames that appear onscreen (zoom in 
or out).

Individual Properties

This section provides settings to the selected graph only.

• Data Item—use this pulldown menu to select individual graphs for modification.

• Auto Scale—minimum and maximum (Y axis) values automatically adjust to the signal when 
the box is checked, uncheck the box if you want to custom set the values.

• Y Axis Range—use to type desired minimum (from) and maximum (to) values in the selection 
boxes. This field is only active when Auto Scale is deselected.

Dialog Box Control Buttons

– OK—applies the changes and closes the properties dialog box.

– Cancel—closes the properties dialog box without making changes.

– Apply—applies the changes and leaves the properties dialog box open.

Help Menu

The Help menu provides Scanner Viewer software version information.
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6.1.2  Display Toolbar

The Display toolbar provides the following controls (Figure 6-9).

• Exit—closes Scanner DataViewer.

• Hide PID List—toggles display between parameter text and graph views.

• Reset—returns the listed parameters to the default sort setting (if previously sorted)

• Display Views (1 to 16)—determines how many graphs display at a time.

• Scale—switches the scale values shown to the left of the graph off and on.

• Sweep—switches the sweep values shown below the graph off and on.

Figure 6-9 Display toolbar

When the window size is too small to display all the toolbar buttons, select more to display the 
hidden options.

Figure 6-10 
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6.1.3  Navigation Tools

Playback Controls

The playback controls allow you to navigate through saved data (Figure 6-11).

1— Skip Back—Allows quick backward movement by graph screen length. Each click moves 
the cursor to the next screen of data, while the cursor remains at the same screen position 
in the next screen of data. 

2— Step Back—Allows backward movement in singular steps.

3— Play—Select to play.

4— Step Forward—Allows forward movement in singular steps.

5— Skip Forward—Allows quick forward movement by graph screen length. Each click 
moves the cursor to the next screen of data, while the cursor remains at the same screen 
position in the next screen of data.

6— Pause—Select to pause playback.
Figure 6-11 Playback controls

Zoom Controls

The zoom controls allow you to incrementally increase or decrease the screen magnification 
(Figure 6-12).

Figure 6-12 Zoom controls
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Slider / Scroll Bars and Cursor

Use the slider bar to quickly navigate through the data (Figure 6-13). During playback the number 
displayed on the left side of the slider bar indicates the current position of the cursor in the data file. 

The cursor can be repositioned during playback or when paused, by selecting and dragging, or by 
double-clicking on the desired new location.

When using the slider bar to navigate through data, the cursor does not move. This allows you to 
mark a point of interest with the cursor, and search for other data of interest, then go back to the 
cursor if needed.

Use the scroll bar (right side) to vertically scroll through the parameter list and graphs.

1— Cursor

2— Scroll bar

3— Slider bar
Figure 6-13 

3

1

2
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6.1.4  Customizing the Display

The parameter text list (left side) displays parameter names and current values.

The display can be customized by selecting and dragging parameters from the text list or graph 
display to a different location in the text list or in the graph display (Figure 6-14). The highlighted 
parameters in the text list indicate which parameters are displayed as graphs.

NOTE:
i The parameter text list is sortable by name and value. Select Name or Value at the top of the list 

to change the sorted view. Use the Reset button to reset the list to the default setting.

Figure 6-14 

6.1.5  Customizing the Parameter List

The parameter configuration tabs allow you to choose between displaying all available 
parameters (Complete List), or only those from a (Custom List) (Figure 6-15).

The parameter listed are sortable (ascending/descending) by clicking on the Name and Value tabs 
at the top of the list.
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z To customize the parameter list:

1. Select the Custom List tab (Figure 6-15).

2. Select Edit List in the custom window.

1— Edit List

2— Custom List tab
Figure 6-15 

A list of available parameters displays (Figure 6-16).

3. Select the parameters to include in your custom list. Select All and Deselect All controls are 
also available to assist in the selection process.

Figure 6-16 Creating a custom parameter list

4. Select Save & Exit to close the window.

Only the parameters selected in your custom list are displayed.

2

1
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6.2   Scope File Viewer
Your ShopStream Connect software allows you to print and playback recorded trace signals 
captured on your diagnostic tool. When a scope file is selected, it opens and displays in the
 Scope File Viewer. 

Scope File Viewer - Opens .ISM, .ISP, .LSM, .LSP, .LSS, .MMM, .MMP, .MMS, .VSM, 
                                   and .VSS file extensions.

NOTE:
i The Scope File Viewer is intended to be used to review scope and meter files originally captured 

on a diagnostic tool. Some features (control icons) of the Scope File Viewer may not be available 
“grayed out”. This is normal as those features are only applicable when viewing live data on a 
diagnostic tool.

The Scope File Viewer screen includes the following sections (Figure 6-17):

1— Toolbar - contains control icons

2— Main Body - displays recorded trace results 

3— Profile Controls Window - displays profile control icons and trace display settings 

4— Playback Control Toolbar - contains playback and display controls
Figure 6-17 Scope File Viewer screen layout
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6.2.1  Toolbar

The Scope Viewer toolbar includes controls to configure display settings and print traces. The 
following table provides brief descriptions of the toolbar controls:

Setup 

Setup includes the following display options for setting preferences to review captured traces.

• Traces - shows original captured trace settings. Changes are not allowed, except adjustment 
of the baseline setting.

• Sweep - shows original captured sweep setting. Changes are not allowed.

• Trigger - shows original captured trigger setting. Changes are not allowed.

• View - allows you to change display settings.

– Display - adjust display information and appearance.

- Show Grid - toggles grid lines on and off.

- Invert Colors - toggles screen background black to white.

- Show RPM - displays RPM display. (Not Used)

– Layout - use to set how many trace display windows are shown and how they display on 
the screen.

– Units - use to adjust trace display settings.

• Setup - shows original captured trace settings.

– Units - shows original captured trace unit setting.

– Snapshot - shows original percentage of how much data was captured after the snapshot 
was triggered.

– Ignition - shows original captured trace ignition setting.

Table 6-1 

Name Icon Description

Setup
Opens preferences submenu to setup personal 
preferences and review captured data settings.

Cursors
Toggles cursor display on/off. Cursors are two 
vertical rules that can be repositioned on the screen 
to measure intervals.

Refresh Not Used - This control is not operational.

File
Opens a dialog box that allows you to select options 
for saving data.

Print
Opens a dialog box that allows you to configure and 
print.

Preview
Opens a dialog box that allows you to preview and 
change page settings before you print.
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Cursors 

Select Cursors from the toolbar to open the Cursors dialog box (Figure 6-18).

1— Cursor 1 controls

2— Cursor 2 controls

3— Back

4— Show or Hide 
Figure 6-18 Cursor controls

Cursor 1, the top slider and arrows, is the left-hand cursor on the screen. Cursor 2, the lower set 
of controls, is the right-hand cursor on the screen. Drag the slider or select the arrows to position 
the cursors. Each tap of the stylus moves the cursor incrementally in the direction of the arrow.

Select Show to display the cursors (the icon changes to Hide).

Select Hide to conceal the cursors (the icon changes to Show).

Select Back to close the dialog box.

Refresh 

This function is not operational in Scope Viewer.

File

Selecting File from the toolbar opens a dialog box with a menu of save options:

• Save Configuration - allows the current settings to be saved using a different name using the 
VSC file format. (.VSC files can be viewed by selecting the Presets tab)

• Save Single Frame - allows the current screen data to be saved using a different name using 
the VSS file format. (.VSS files are “single frame” or partial files)

• Save All Frames - allows the current file to be saved using a different name using the VSM 
file format. (.VSM files include “all frames” or complete files)
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z To save a file:

1. Select File from the toolbar.

2. Select a Save option from the dialog box.

Figure 6-19 Save options

The Save As dialog box opens.

3. Select the location where you want the file to be saved, and name the file.

4. Select Save.

A file description dialog box opens.

NOTE:
i The description entered here is what displays in the Notes Window panel of the Data Manger main 

screen.

5. Enter a description of the file.

6. Select OK.

7. Select OK to close the file setup dialog box.

Print 

Selecting Print opens dialog box (Figure 6-15). choose one of the following:

– Select Yes to print only the Scope window

– Select No to print the entire screen

Figure 6-20 

A standard Windows Print dialog box opens.

Make the desired print setting selections, then select OK to print. 

Print Preview 

Selecting Print Preview opens a print preview window. The Print Preview menu options allow you 
to adjust the page layout before printing.
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6.2.2  Main Body

The main body of the screen varies depending on what display options have been selected. Up to 
four traces, signal status and triggering conditions can be displayed simultaneously on the main 
body of the screen.

Each trace is displayed on a standard oscilloscope screen. 

• The vertical scale (Y-axis) represents what is being measured (voltage, amperage, pressure 
etc.), and the unit of measurement it is displayed in. 

• The horizontal scale (X-axis) represents time, and the unit of measurement it is displayed in.

Trace adjustments are made from the Toolbar and the Profile Controls window. From the main 
body you can adjust:

• Cursor position: touch and drag the cursor to reposition it.

• The baseline position (0 value) of the trace can be repositioned on the horizontal scale by 
touching and dragging the solid bar at the right-side of the channel baseline.

6.2.3  Profile Controls Window

The Profile Controls Window displays the original captured trace profile settings. 

Figure 6-21 Profile Controls Window

Profile settings cannot be changed, except the signal channel Show/Hide settings. 

The show/hide trace icons are used to toggle the displayed signal channel off/on.

Select the icon to toggle the channel off/ on.

NOTE:
i Selecting the Channel number from the Profile Control Window opens the Trace Setup dialog box. 

The Trace Setup dialog box shows the original captured trace settings. Changes are not allowed, 
except for the zero baseline setting.

NOTE:
i Selecting the Trigger indicator from the Profile Control Window opens the Trigger Setup dialog 

box. The Trigger Setup dialog box shows the original captured trace settings. Changes are not 
allowed.

Show/Hide Icon Description

On Channel displayed

Off Channel not displayed
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6.2.4  Playback Control Toolbar

The playback control toolbar includes navigation controls to review recorded data, change the 
display view and change the screen magnification. 

Figure 6-22 Playback Controls Toolbar

A position counter in the toolbar displays a numerical value of where the current displayed screen 
is in relation to the entire recorded file.

Use the slider in the middle of the toolbar to quickly move through paused data.

Table 6-2 Data buffer toolbar icons

Name Icon Description

Step Back Allows backward movement in singular steps

Skip Back Allows backward movement in multiple steps

Stop Stops playback

Play
Starts playback. Plays the recording in a continuous 
loop.

Skip Forward Allows forward movement in multiple steps

Step Forward Allows forward movement in singular steps

Position Indicator Numerical playback position indicator

Expand/Collapse
Toggles Main body view between split and full profile 
views

Zoom
Increases or decreases the magnification of the 
display
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6.3   Image Viewer
The Image Viewer allows you to open and view .bmp, .jpg and .sps image files (screenshots). 

NOTE:
i File extension types vary depending on the diagnostic tool. Not all the file extensions described 

here may be available on your diagnostic tool.

1— Exit - closes the Image Viewer

2— Print - prints the image

3— Print Preview - allows the image to be previewed before printing

4— Captured Screen Image
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6.4   Scanner Codes Viewer
The Scanner Codes Viewer allows you to view and print XML trouble code files from your 
diagnostic tool. XML trouble code files can be saved when codes are read from an individual 
vehicle system or when performing a Code Scan of multiple systems.

NOTE:
i XML files are not applicable on all diagnostic tools. 

XML file formats vary depending on the diagnostic tool. Examples are shown in the following 
sections, with descriptions of toolbar functions.

6.4.1  Vehicle System Report Screen
On select diagnostic tools (e.g. MODIS Edge), results are displayed using an enhanced report 
format, utilizing colors and icons as quick visual indicators of important data.

Figure 6-23 Typical - Vehicle System Report Screen
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6.4.2  Results Screen
A typical Code Scan results screen is shown below. This screen includes the following toolbar 
options:

1— File - opens the Exit submenu 

- Exit - closes the Scanner Code Viewer

2— Print - prints the XML file

3— Print Preview - allows the image to be previewed before printing

4— Help - Includes the following submenus

- About Scanner Codes Viewer - displays Scanner Code Viewer software version 
information

Figure 6-24 Scanner Codes Viewer Toolbar

31 2 4
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6.4.3  Print Preview Screen
A typical Code Scan print preview screen is shown below. This screen includes the following print 
preview toolbar options:

1— Print (icon) - prints the XML file

2— Zoom In/Out (icons) - Increases/decreases the onscreen magnification

3— View Page Width (icon) - Displays the page to the window width

4— View Entire Page (icon) - Displays the entire page inside the window

5— View All Pages (icon) - Displays all pages inside the window 

Figure 6-25 Scanner Codes Viewer Print Preview Toolbar

1 32 4 5
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7.1   File Transfer Basics
ShopStream Connect uses a basic Windows interface and familiar copy, paste, move and drag 
and drop controls to allow you to transfer files bi-directionally between your diagnostic tool and 
your PC.

To transfer files bi-directionally between your diagnostic tool and your PC, the following basic 
procedures must be performed:

• Start the ShopStream Connect application, see “Starting SSC” on page 10 

• Connect the diagnostic tool, see “Connecting the USB Cable and Communicating” on 
page 12

7.1.1  Folder and Files

When a diagnostic tool is connected to your PC using ShopStream Connect, a diagnostic tool 
folder is created on your PC named after the platform (e.g. Vantage PRO, MODIS Ultra, etc). This 
folder allows you to store and transfer files.

The location of the diagnostic tool “target destination” folders on your PC is defined during the 
installation of ShopStream Connect. The “target destination” folder names and location can be 
changed at anytime by choosing (from main menu) Tools > Options > Change ShopStream 
Data Path. Follow the onscreen instructions to create or rename your new “target destination” 
folder and/or location. See “Change ShopStream Data Folder Path” on page 24 for additional 
information.

7.1.2  Displaying Files

From the ShopStream Connect Main Screen, you can display the File Directory Structure (left 
side) which shows folders on your PC and the diagnostic tool (if connected to PC). The Data tab 
on the Main Display, displays only ShopStream Connect compatible files within the folders. 

• To display data files on your diagnostic tool, select your diagnostic tool from the File Directory 
Structure window (e.g. <E> MODISULTRA) and files stored on the diagnostic tool are 
displayed in the Data tab on the Main Display window. 

Figure 7-1 
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• To display data files on your PC, select your “target destination” folder from the File Directory 
Structure window (e.g. <C> ShopStream \ MODIS Files) and the files stored on your PC are 
displayed in the Data tab on the Main Display window. See “Data Manager Screen Controls 
and Icons” on page 25 for additional information.

Figure 7-2 

NOTE:
i If the optional “Autostart” control is activated, whenever you connect your diagnostic tool (or 

memory card) to your PC, the ShopStream Connect software on your PC will automatically 
recognize your diagnostic tool and open the ShopStream Connect interface. The “Autostart” 
feature can be turned on or off by selecting or deselecting it from the options submenu Tools > 
Options > Autostart. A check mark alongside “Autostart” indicates the feature is active, see 
“Autostart” on page 22.

From the ShopStream Connect Main Screen, you can also transfer files bi-directionally between 
your diagnostic tool and your PC using the following methods:

7.1.3  Copying Files

The “Copy To” and “Copy Files” functions create a duplicate of the selected file or files on either 
the PC or the diagnostic tool. These controls are available from the Main Menu Bar, Data Manager 
Toolbar or by selecting the file and right clicking and choosing from the dropdown menu. See 
“Copy To” on page 31 for additional information.

7.1.4  Moving Files

The “Move To” function moves the selected file or files to either the PC or the diagnostic tool. 
These controls are available from the Data Manager Toolbar or by selecting the file and right 
clicking and choosing from the dropdown menu. See “Move To” on page 31 for additional 
information.

Files can also be moved by selecting the file and using the Windows-standard drag-and-drop 
functionality. Simply select the file (left click mouse button and hold) and drag the file to the desired 
location in the File Structure Directory and drop it (release left mouse button).

7.1.5  Alternate Method

Files and folders can also be moved, copied and renamed using the standard Windows Explorer 
interface. Select files and folders from within Windows Explorer and move, copy, delete or rename 
using the standard Windows controls. 
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Chapter 8 Updating and Upgrading 
Software

This chapter describes procedures for downloading and installing SSC software updates, and 
diagnostic tool software (service releases), and upgrades (new software versions):

• Software Updates for ShopStream Connect 

• Software Updates (Service Releases) for Diagnostic Tools 

• Software Upgrades for Diagnostic Tools

There are two software update/upgrade methods:

• Automatic Method — When a compatible Snap-on diagnostic tool is connected to a PC 
using ShopStream Connect (SSC), the SSC software will automatically check for updates/
upgrades and provide installation instructions. Follow the screen prompts to accept, download 
and install the software.

• Manual Method — To manually check for software updates/upgrades select Tools > Update 
Software, then select either ShopStream Connect or your diagnostic tool (diagnostic tool 
type - e.g. MODIS, SOLUS PRO, Vantage Pro etc.) from the Menu bar.

The following procedures are described using the manual method. The automatic method 
navigation procedures are the same, except the initial Tools menu selection is not needed as the 
program checks for updates/upgrades automatically. 

z Initial Steps:

Perform the following initial steps before proceeding.

1. On your PC start the SSC software program.

2. Connect the AC/DC power adapter to the diagnostic tool (if applicable). It is highly 
recommended to power the tool using the adapter during any update or upgrade procedure.

3. Connect your diagnostic tool to the PC. See the applicable instructions for connecting and 
establishing communication your diagnostic tool to a PC. See, “Connecting the USB Cable 
and Communicating” on page 12.

NOTE:
i The SSC software must be able to access the Internet on your PC.
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8.0.1  Software Updates for ShopStream Connect

z Updating ShopStream Connect software:

1. Select Tools > Update Software > ShopStream Connect from the Menu bar (Figure 8-1).

Figure 8-1 

The software checks the Snap-on Web server for available updates.

2. If updates are available, select Next to continue, then select Download and follow the on-
screen instructions to complete the installation (Figure 8-2).

Figure 8-2 
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8.0.2  Software Updates (Service Releases) for Diagnostic Tools

z Updating diagnostic tool software:

1. Select Tools > Update Software > (diagnostic tool type - e.g. MODIS, SOLUS PRO, 
Vantage Ultra etc.) from the Menu bar (Figure 8-3).

Figure 8-3 

The software checks the Snap-on web server for available updates.

2. If service release updates are available, select Next to continue, then select Download and 
follow the on-screen instructions to complete the installation (Figure 8-4).

Figure 8-4 

8.0.3  Software Upgrades for Diagnostic Tools

z Upgrading diagnostic tool software:

1. Select Tools > Update Software > (diagnostic tool type - e.g. MODIS, SOLUS PRO, 
Vantage Ultra etc.) from the Menu bar (Figure 8-5).

Figure 8-5 

• If the diagnostic tool is authorized to receive software upgrades and one is available, an 
upgrade window is displayed (see step 2).

• If the diagnostic tool is authorized to receive software upgrades and already has the latest 
software, the following message will be displayed “ShopStream Connect did not find any 
updates”.
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• If the diagnostic tool is not authorized to receive software upgrades, SSC software will 
automatically check the Snap-on web server for a Service Release update. If a Service 
Release update is available, an update window is displayed. Follow the screen prompts to 
install the Service Release update.

2. Read and follow the instructions displayed in the message box, then select Install to begin the 
download and installation (Figure 8-6).

NOTE:
i Selecting Upgrade Detail automatically connects to the Snap-on web server and opens a PDF file 

with information about the new upgrade. 

Figure 8-6 

The Online Update status window is displayed (Figure 8-7).

Figure 8-7 
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3. After the download is complete, the installation confirmation message is displayed. Select 
Continue to proceed with the software upgrade installation (Figure 8-8).

Figure 8-8 

The Programming status window is displayed until programming is completed. Once 
programming is completed select Exit, then restart the diagnostic tool (Figure 8-9).

IMPORTANT:
Do not disconnect or remove the diagnostic tool during programming.

Figure 8-9 
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Appendix A Communicating with Early 
MODIS diagnostic tools

The original MODIS printed circuit board design did not have a Mini-b USB port by the side 
CompactFlash® (CF) card slot. Therefore, these diagnostic tools cannot be directly linked to a 
computer with a USB cable. However, it is possible to view files stored on an early MODIS with the 
ShopStream ConnectTM software, it just requires a few extra steps.

A.1   Viewing Early MODIS Files
A CF card reader that connects to your personal computer (PC) is required to view early MODIS 
files. The CF reader is a standard item that may be purchased from most computer and office 
supply retailers.

z To view early MODIS files:

1. Turn off the MODIS diagnostic tool.

2. Remove the CF card from your MODIS.

3. Connect the CF card reader to your PC and insert the MODIS CF card.

4. If a “removable disk” dialog automatically opens on your PC, select Cancel.

5. Launch ShopStream Connect.

ShopStream Connect should recognize the CF card as a MODIS and show it as an available 
selection in the directory tree. If not:

a. Open the CF card through Windows®.

b. Open the User folder, then open the Data folder.

A list of saved data files displays.

c. Copy the files you want to view in ShopStream Connect.

d. Open the target folder (C:\Documents and Settings\All Users\Application 
Data\ShopStream\MODIS Files) on your computer.

e. Paste the files into the target folder.

These files are now ready for viewing with ShopStream Connect.

IMPORTANT:
Do not change or alter files in any of the other locations on the CF card, as this could impact the 
operation of your MODIS diagnostic tool
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A.2   Service Releases and early MODIS diagnostic tools

z To deliver service releases to early MODIS diagnostic tools:

1. Turn off the MODIS diagnostic tool.

2. Remove the CF card from your MODIS.

3. Connect the CF card reader to your PC and insert the MODIS CF card.

4. If a “removable disk” dialog automatically opens on your PC, select Cancel.

5. Launch ShopStream Connect.

6. ShopStream Connect should recognize the CF card as a MODIS and show it as an available 
selection in the directory tree.

7. Select the MODIS from the directory tree.

Refer to “Software Updates (Service Releases) for Diagnostic Tools” on page 58 to complete the 
update.
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